This project is read-only.

Failed to connect to Reporting Service

May 27, 2010 at 4:19 PM

I am running SQL 2005 with the Reporting service webapp on port 8080.  I have been able to connect to the site

http://localhost:8080/ReportServer/

with my user credentials that I use in the $ssrs_report = new SSRSReport(new Credentials(UID, PASWD), SERVICE_URL);    line of code but I continue to get the following message

Failed to connect to Reporting Service
Make sure that the url (http://localhost:8080/ReportServer/) and credentials are correct!

Any ideas what I could be missing

May 28, 2010 at 5:01 PM

Hi adunckel

Did you configure the server like they say in the server guide?

I have that problem and with me was because i have the configurations of the server wrong, have to add the <RSWindowsBasic/> in the Authentication types of the rsreportserver.config file.

You should look at the guide that comes with the sdk to configure the reportserver, it helps with me.

Hope it helps you, good luck

 

Regards

 

May 28, 2010 at 6:20 PM

Prx's suggestion should solve the problem. the authentication issue is likely to be caused by Windows Basic authentication not being enabled.

Thanks

Claudio

 

May 28, 2010 at 7:02 PM

I did go through the guide already and I found the following in rsreportserver.config

        <Authentication>
            <Extension Name="Windows" Type="Microsoft.ReportingServices.Authentication.WindowsAuthentication, Microsoft.ReportingServices.Authorization"/>
        </Authentication>

Is this the correct place?

I am not sure if this is an issue with my using SQL2005 rather than 2008 and thus the file looks different or if I am missing something.

Thanks for your responses.

May 28, 2010 at 7:29 PM

I got it.

In SQL2005 you need to change the authentication type under IIS not in the config file.  I read that in the guide but I must have ignored it.

Thanks for the help