1
Vote

Not compatible with PHP version 5.5+

description

Hi,

I'm using the SSRS SDK For PHP which has not been updated since years surprisingly (08.04.2010) . It works fine under PHP 5.4 (5.4.44) but not under 5.5+ (5.5.37, 5.6.28, 7.x)

The error is :

array ( )Failed to connect to Reporting Service Make sure that the url (https://myHostURL:60004/ReportServer/) and credentials are correct! The exception is thrown in line 207 because the var $content is equals to FALSE (so can't load the content).

It's perfectly fine with PHP 5.4.44.

I can't find the "SSRS SDK For PHP" documentation regarding the PHP version supported...

I'm not using any framework such as Symfony2, CakePHP, Zend Framework,... except Bootstrap.

Does anyone know or have figured out this issue?

comments